IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Scheduler Pro remote access., How to configure Windows 10 firewall
AMal
post Nov 4 2016, 04:41 AM
Post #1


Be nice to me, I am new.


Group: New Members
Posts: 7
Joined: 23-March 13
Member No.: 15,341
Card: DNTV TinyTwin USB


Can anyone tell me how to configure Win 10 firewall to allow access to TV Scheduler Pro from another PC on the local network.
I can make it work if I switch the firewall off, but clearly that is undesirable.
Go to the top of the page
 
+Quote Post
frednerk33
post Nov 4 2016, 06:09 PM
Post #2


Forum Regular


Group: New Members
Posts: 311
Joined: 29-April 06
From: australia
Member No.: 4,667
Card: DNTV TinyTwin USB


QUOTE (AMal @ Nov 4 2016, 05:11 AM) *
Can anyone tell me how to configure Win 10 firewall to allow access to TV Scheduler Pro from another PC on the local network.
I can make it work if I switch the firewall off, but clearly that is undesirable.

One way, an easy way, is to trust the PCs on both ends of the http traffic.

On the TV Scheduler Pro PC :-
Start, Control Panel, Windows Firewall, Advanced Settings
Add an inbound rule; all programs, no remote computers, you could put in a local port (8420) if you wanted or leave it blank, scope's IP "remote IP" of the target IP (give both PCs permanent DHCP IP address reservations in your router first, if they're not already fixed IPs), tick private under advanced, the rest blank.
Then add an outbound rule that looks similar.

Do similar on the querying PC to trust the TV Scheduler Pro PC.

If you leave the port blank, it is a fully trusted path, file shares and whatnot get through nicely ... just properly protect both PCs with antivirus and whatnot; Windows Defender seems to work.

See how you go.
Go to the top of the page
 
+Quote Post
AMal
post Nov 4 2016, 08:23 PM
Post #3


Be nice to me, I am new.


Group: New Members
Posts: 7
Joined: 23-March 13
Member No.: 15,341
Card: DNTV TinyTwin USB


QUOTE (frednerk33 @ Nov 4 2016, 08:09 AM) *
One way, an easy way, is to trust the PCs on both ends of the http traffic.

On the TV Scheduler Pro PC :-
Start, Control Panel, Windows Firewall, Advanced Settings
Add an inbound rule; all programs, no remote computers, you could put in a local port (8420) if you wanted or leave it blank, scope's IP "remote IP" of the target IP (give both PCs permanent DHCP IP address reservations in your router first, if they're not already fixed IPs), tick private under advanced, the rest blank.
Then add an outbound rule that looks similar.

Do similar on the querying PC to trust the TV Scheduler Pro PC.

If you leave the port blank, it is a fully trusted path, file shares and whatnot get through nicely ... just properly protect both PCs with antivirus and whatnot; Windows Defender seems to work.

See how you go.

Hi "frednerk33", Thanks for your prompt response.
I have tried your suggestion, but without luck.
Incidentally, this is a new installation. I'm using Windows 10 x64 with TV Scheduler Pro 2 (latest download) and it seems to use port 8088 rather than 8420 (as my older version running on Win7 did).
I've tried both port numbers without success.
If I switch off the firewall on the Scheduler machine, all works fine, so it must be a firewall config issue on that machine.
I agree with your comment about Windows Defender, but I feel unsafe without a firewall.

Regards, Alan
Go to the top of the page
 
+Quote Post
frednerk33
post Nov 5 2016, 05:16 PM
Post #4


Forum Regular


Group: New Members
Posts: 311
Joined: 29-April 06
From: australia
Member No.: 4,667
Card: DNTV TinyTwin USB


QUOTE (AMal @ Nov 4 2016, 08:53 PM) *
Incidentally, this is a new installation. I'm using Windows 10 x64 with TV Scheduler Pro 2 (latest download) and it seems to use port 8088 rather than 8420 (as my older version running on Win7 did).
I've tried both port numbers without success.
If I switch off the firewall on the Scheduler machine, all works fine, so it must be a firewall config issue on that machine.
I agree with your comment about Windows Defender, but I feel unsafe without a firewall.

OK, is mine Win10 x64 too.
What is "TV Scheduler Pro 2" and where did you download it ? Here https://sourceforge.net/projects/tvschedulerpro/ ?
I suppose it's likely this one http://www.digitalnow.com.au/DNTVscheduler.html
Port shmort smile.gif Put in the one that suits or better still leave it out to trust the other machine. After all, both are your trusty well configured and safe PCs, right ?
Turning off our firewalls would be like lifting our skirts and giving a wink and a nod.
Care to post pics of the pair (incoming, outgoing) of firewall rules settings which you would have created on both of your 2 machines, where you have ticked something or entered something ?
Also make sure the pairs of rules are enabled on both machines.
Definitely works on mine.
I tend to suspect your router DHCP IP reservations are not set so as to ensure that your 2x PCs always get the same IPs after reboots. Assuming you don't play with a non-DHCP IP exclusion range and fixed-IPs in the PCs. (The firewall rules you created were known-fixed-IP-address based).

Cheers
Go to the top of the page
 
+Quote Post
AMal
post Nov 8 2016, 10:02 PM
Post #5


Be nice to me, I am new.


Group: New Members
Posts: 7
Joined: 23-March 13
Member No.: 15,341
Card: DNTV TinyTwin USB


QUOTE (frednerk33 @ Nov 5 2016, 07:16 AM) *
OK, is mine Win10 x64 too.
What is "TV Scheduler Pro 2" and where did you download it ? Here https://sourceforge.net/projects/tvschedulerpro/ ?
I suppose it's likely this one http://www.digitalnow.com.au/DNTVscheduler.html
Port shmort smile.gif Put in the one that suits or better still leave it out to trust the other machine. After all, both are your trusty well configured and safe PCs, right ?
Turning off our firewalls would be like lifting our skirts and giving a wink and a nod.
Care to post pics of the pair (incoming, outgoing) of firewall rules settings which you would have created on both of your 2 machines, where you have ticked something or entered something ?
Also make sure the pairs of rules are enabled on both machines.
Definitely works on mine.
I tend to suspect your router DHCP IP reservations are not set so as to ensure that your 2x PCs always get the same IPs after reboots. Assuming you don't play with a non-DHCP IP exclusion range and fixed-IPs in the PCs. (The firewall rules you created were known-fixed-IP-address based).

Cheers

Hi frednerk33,
It's all working now!
I wish I knew what the trick was. I followed your helpful suggestions and as I reported, it didn't work, but hey after a service update to Windows 10 (which took ages), and several reboots, all seems well.
Incidentally, I did download from the digitalnow site - from which I got my hardware.
Thanks again for your comments.
Cheers
Go to the top of the page
 
+Quote Post
frednerk33
post Nov 8 2016, 11:12 PM
Post #6


Forum Regular


Group: New Members
Posts: 311
Joined: 29-April 06
From: australia
Member No.: 4,667
Card: DNTV TinyTwin USB


QUOTE (AMal @ Nov 8 2016, 10:32 PM) *
Hi frednerk33,
It's all working now!
I wish I knew what the trick was. I followed your helpful suggestions and as I reported, it didn't work, but hey after a service update to Windows 10 (which took ages), and several reboots, all seems well.
Incidentally, I did download from the digitalnow site - from which I got my hardware.
Thanks again for your comments.
Cheers

Well strike me pink, that's good news for you.
Have fun,
Fred.

Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2019 - 06:31 PM