Welcome Guest ( Log In | Register )

Reply to this topicStart new topic
> Losing focus with XP MCE and PowerDVD, Remote jumps back to MCE when PowerDVD is running
post Oct 3 2009, 12:31 PM
Post #1

Be nice to me, I am new.

Group: New Members
Posts: 1
Joined: 3-October 09
Member No.: 12,593
Card: None

Howdy all! I would be grateful for any help anyone could give on two problems I am having with HIP.

I'm running Windows XP MCE, SP3. I am using an Anyware GP-IR01BK. It is certified for Vista and works great with my Vista machine, but due to frustrations I've had with running Vista 64 and trying to get 3rd party add-ins working with it, I've decided to try using XP.

Anyway, I was able to get the IR transceiver installed using the hack where you modify the irbus.inf file to recognize it. Worked great in getting that installed, but nothing would happen when I used the remote, so it was suggested I install HIP.

Well, that has worked out partly well. The part that has worked out is that in setting it up with the MCE v2 profile that came in the download, it seems to work flawlessly with WMC. However, as I intend to watch HD-DVD's and Blu-Rays, I have PowerDVD 8 installed as well. I installed a great little program that adds PowerDVD to the menu in WMC where it launches PowerDVD. That part works great.

I set up a Program 2 in HIP to handle PowerDVD. If I launch PowerDVD from the start menu, the remote works fine (with one small detail that I'll get to later). The problem comes if I use the menu in WMC to launch PowerDVD. POwerDVD opens up, but anytime I push a button on the remote, WMC pops back up. It seems that HIP doesn't realize that I have launched PowerDVD.

So, anyway to fix that? That's the big issue.

The smaller issue is that I was trying to map the DVD Menu button in HIP for PowerDVD. I can get it to register (in the command section it will say DVD Menu then "J", which is the keyboard command to enter the menu, and then the key code), but pressing it does nothing. As a test, I mapped the #1 on the remote to "J" and it takes me right to the menu perfectly. To be clear, when I open a DVD in WMC, the DVD Menu button on the remote works fine. So HIP is recognizing it, just not for my PowerDVD setup.

Any ideas why that is not working? While that work around would be functional, it's not ideal. My wife will be using this as well as me, and if she has to remember to hit "1" (or something else) when in PowerDVD, she's not going to be happy!

Thanks for the help!
Go to the top of the page
+Quote Post
post Nov 4 2009, 10:25 AM
Post #2

Forum Regular

Group: Members
Posts: 1,581
Joined: 8-October 03
From: Adelaide
Member No.: 185
Card: DNTV Live! DVB-T

I am not sure what to recommend you do with your PowerDVD problem because Hip is contantly polling the application in focus to work out what keyset to use and it is likely that the PowerDVD display window is not being recognised as being part of the program. I wrote a program called ActiveWin which is available here: http://www.byremote.com.au/downloads/download.asp?SID=19 which may help you to work out why Hip does not know that PowerDVD is the window with focus.

I suspect that your utility, does not pass focus to PowerDVD after it has started which is why your commands are note being seen by it.

Trying to debug commands can be complicated because you need to work out if the problem is with the translation of the key pressed, or the command sent. Firstly, turn on sounds so you can hear when a key is recognised by Hip. Then try assigning a different command to the DVD menu key to see if that works. Does PowerDVD have any other way other than keyboard commands to control the interface?

Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 22nd June 2018 - 03:10 PM