IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Configuration for PowerDVD 9 Ultra filter
stevebow
post Aug 30 2009, 11:31 AM
Post #1


Participant


Group: New Members
Posts: 33
Joined: 16-January 07
From: Sydney, Australia
Member No.: 6,720
Card: None


I just upgraded my PowerDVD 7 Ultra to PowerDVD 9 Ultra, only to find DW no longer was showing any video, because the CLSID for the decoder has changed between versions and the PowerDVD upgrade process removes the old decoder completely.

To fix this, open the Decoders.xml file and add the following lines - right after the Cyberlink7 decoder entries would be a good place:

CODE
<Decoder name="Cyberlink9 Video Decoder">
    <MediaType name="MPEG2 Video" />
    
    <LoadFilter clsid="{3AC8EA8C-990A-424A-BD7B-D5B57A9DEB83}" name="Cyberlink9 Video Decoder" />
    <InputFilter name="Cyberlink9 Video Decoder" />
    <VideoRenderer name="Overlay Mixer" />

    <Connect>
        <From name="Cyberlink9 Video Decoder" />
       <To name="Overlay Mixer"/>
       </>
</Decoder>

<Decoder name="Cyberlink9 Video Decoder - VMR9">
    <MediaType name="MPEG2 Video" />
    
    <LoadFilter clsid="{3AC8EA8C-990A-424A-BD7B-D5B57A9DEB83}" name="Cyberlink9 Video Decoder" />
    <InputFilter name="Cyberlink9 Video Decoder" />
    <VideoRenderer name="VMR9" />

    <Connect>
        <From name="Cyberlink9 Video Decoder" />
       <To name="VMR9"/>
       </>
</Decoder>

Next, start DW. When started, you should still hear audio but have no video. Next press"k", then go into "Settings". Go down to "A - V Decoders", then "MPEG2 Video". Scroll down the list and the two Cyberlink9 entries you added above should appear in the list. Select the most suitable filter; you should now see video. Press "x" to quit DW and save the setting.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2018 - 12:03 AM