IPB

Welcome Guest ( Log In | Register )

6 Pages V   1 2 3 > »   
Reply to this topicStart new topic
> Digitalwatch 2.0.7.*
bear
post Jun 11 2006, 02:23 PM
Post #1


Forum Regular


Group: Members
Posts: 3,100
Joined: 24-April 04
From: Queensland
Member No.: 808
Card: VisionPlus DVB-t


Hi everyone,
I thought I would start a new thread with a beta release of version 2.0.7.0. I will update this first post with any changes that happen so everyone can reference it later.

ATM, you can get the latest beta version from here. Thanks Andy

ATM, you can read the Manual from here. Thanks Richard.

The source code for the application can be found here. Thanks nate.

And a big thanks to all who have been patient and helpful with the testing so far.

I have uploaded version 2.0.7.6 to the SVN & this link DW-2.0.7.6.zip

Version 2.0.7.6
bear:
Changes:
- Added some code to solve a thread crashing issue where it was trying to start a thread when it was already running.
- Fixed a problem with the SetDSNetworkPort function where it was causing a crash when the value was less than 4 digits.
- Added a option for a basic surface key render for DigitalWatchSaver so the OSD uses less cpu for slower systems. Default is False.
- Added a Screen Saver disable option for paused playback to the settings.xml, also will now disable screensaver if the application has been minimised with the quiet on minimised option enabled.
- Updated TSFileSource Filter ver 2.2.0.8 Beta 6.

u]Version 2.0.7.3[/u]
bear:
Changes:
- add signal strength/quality back into the DigitalWatch OSD (used the "S" key).

Version 2.0.7.2
bear:
Changes:
- Added in some audio muting when changing channels.
- Made some changes to fix the multiple audio stream problem when timeshifting. @anthony, if you could try this, thanks.
- Fixed a bug that was causing crashes when accessing the message log writer. I think.
- Added in a option setting to the OSD menu global settings to enable ordering of the services by channel numbers. Default setting is enabled.


Version 2.0.7.1
bear:
Changes:
- Changed the SetChannel(ONID) method to SetChannel(TSID) for the changes earlier.
- Changed the OSD network/channel display to now parse the transport Stream ID rather than the Original Network ID, this is so uk users can navigate the services since they have the same ONID values for the same frequency.
- Added a buffer log message limit vale to the settings.xml, you can now specify how many messages are buffered before a file write is made, default value is 100. Setiing the value to 0 will cause the log to write to file imediate.
- Added a low priority buffer thread class to the Log Writer, it will now buffer any log messages and write them with it's own low priority thread.


@nate, when you get a chance, let me know how you feel about me making a formal release on your behalf. I have updated the DW SVN website with the latest details so far and will be making more changes as we begin documentation.


Things still to be looked at:

- Change the method of setting the channel from using the ONID value to the TSID value for UK users who have the same ONID for different frequencies.
- Add a Menu feature to point the application to different frequency.xml files to make it easier to add networks in other locations similar to WS auto scan.
- Add in a aspect mode setting to the decoders list so we can indicate if a decoder can auto set its aspect ratio.
- Add in a mode setting to the decoders list so we can decide if we need to restart the application with a channel change.
- DScalar Video decoder does not work in timeshifting, it has seeking issues with the TSFileSource Filter.
- Minimise File Logging to reduce file accessing issues with anti-virus programs.
- Latest TwinHan BDA drivers 1.2.3.8 install a virtual driver that confuses DW card detection and results in not DTV cards found.
- Mute the audio when changing channels.
- Fix a crashing bug that was introduced by the log buffer code.
- Fix an audio 2 problem in timeshifting.

Things still to be looked at sometime:
- Move the OSD for the decoder test indication.
- Remove the "C" indication when changing channel, still debating this.
- Add in more info about current settings to the settings menu info line.
- Add channel number ordering in the services list.
- add signal strength/quality back into the DigitalWatch OSD (used to be the "Q" key).
- add in a ShellExecute function implemented in OSD.
- Think about adding in EPG info.
- Think about adding in DVB-S support.

This post has been edited by bear: Mar 29 2008, 12:19 AM
Go to the top of the page
 
+Quote Post
Guest_Spoonfed_*
post Jun 11 2006, 04:16 PM
Post #2





Guests






I've got love TV seemingly pretty stable now. But totally have lost timeshifted TV. The time shift buffer starts, file is created etc etc BUT in the filter list there is only

DW MPEG-2 Demultiplexer then
TSFileSource

and thats all

If i used for example V64 i get the above at the end of the list of filters with all the other filters before these.

Ideas?
Go to the top of the page
 
+Quote Post
bear
post Jun 11 2006, 04:46 PM
Post #3


Forum Regular


Group: Members
Posts: 3,100
Joined: 24-April 04
From: Queensland
Member No.: 808
Card: VisionPlus DVB-t


QUOTE
Ideas?
Just a note that when you try a new version that you extract to a new location and run the application to build the files it needs, then you should add the networks and then test the features. Try that first if you have not done that already.
Go to the top of the page
 
+Quote Post
Guest_Spoonfed_*
post Jun 11 2006, 05:16 PM
Post #4





Guests






Oops, my bad, haha

Just made quite a few custom changes to the key files, which still work if cut and paste into the new version created files anyway.

seems sweet now, will keep playing.

Tis heaps cool the card cycling, and multi channel timeshifting, might have to dig out the old kworld card and chuck in the machine also biggrin.gif

I cool feature would be if WebScheduler could some how send up a flag just before capture that DW2 looked for, and if WS was about to capture one got the option to release the card to WS?

Now sure im being gready now but is Now and Next available with this DW2 version?

Keep up the good work, awsome stuff

This post has been edited by Spoonfed: Jun 11 2006, 05:27 PM
Go to the top of the page
 
+Quote Post
Guest_Spoonfed_*
post Jun 11 2006, 05:42 PM
Post #5





Guests






Me again, got excited too early. Same thing again. Timeshiftting is up the "shift" haha.

While starting with a fresh new version re scanning channels, settings etc seemed to be the fix, perhaps it was just luck? Did this again and still just the two filters get created in Timeshift mode. hmmmm
Go to the top of the page
 
+Quote Post
bear
post Jun 11 2006, 05:51 PM
Post #6


Forum Regular


Group: Members
Posts: 3,100
Joined: 24-April 04
From: Queensland
Member No.: 808
Card: VisionPlus DVB-t


QUOTE
Just made quite a few custom changes to the key files, which still work if cut and paste into the new version created files anyway.
I will try to indicate what files may change from time to time, this may help. As Richard & myself work on the documentation, alot of the do's & don'ts will help.

QUOTE
Tis heaps cool the card cycling, and multi channel timeshifting, might have to dig out the old kworld card and chuck in the machine also
I think the best config is to enable two cards only unless to switch to TS Mux for timeshifting. It depends on the capability of the HDD setup, my system can only handle three full Mux Timeshifting, if I want to record something then I need to drop the unused timeshift graphs and then record. You can do this if you have "close buffers on minimise" enabled in the global settings. Then you just minimise the application and restore it to clear the buffers.

QUOTE
I cool feature would be if WebScheduler could some how send up a flag just before capture that DW2 looked for, and if WS was about to capture one got the option to release the card to WS?
If you can make a batch file to make windows minimise DW then with the above feature it could make this happen I guess.

QUOTE
Now sure im being gready now but is Now and Next available with this DW2 version?

Not ATM, maybe next main release. If your timeshifting then you can press the "u" key to get a list of the player streams and then if you select the first selection "Program Info" it should give you the N&N in a popup.
Go to the top of the page
 
+Quote Post
anthonyshephard
post Jun 11 2006, 05:52 PM
Post #7


Forum Regular


Group: Members
Posts: 141
Joined: 21-November 04
Member No.: 2,060
Card: VisionPlus DVB-t


QUOTE (bear @ Jun 11 2006, 09:57 AM) *
hi anthony, Thanks for all this feedback.
I'm not sure how this could be worked around but I guess you just did. Ideas anyone?
I think writing out to the log file at every event is unusual. Great for debugging but perhaps not for production.
QUOTE
Can you try deleting the channels.xml file and re-loading your networks to see if that solves it.
I had to. If I didn't do this, the networks still had the short name. Hence my comment about storing the long name regardless of the LongNetworkName setting in the Settings.xml file. I tried again with V70 anyway to make sure and the same behaviour.
QUOTE
Here in AU we have only one program per network so its easy for me to use.

QUOTE
Try using TS Mux format, Also try recording/captureing a channel using full Mux format and then play the file back in DW and use the "U" key to change between services.
That explains why not many people will have experienced changing within the Mux with time shifting on.
I recorded a full mux and can switch between it fine when playing back. With TSMux in timeshifting I can change channels (takes about 4 seconds), but I loose audio for any channels that was not the one I started with. With FullTS, I now seem to be able to change channels within the Mux fine. How strange. Still some problems though, I can't swap networks, I still get the same channel, even though the display changes. Probably related to seeing the same channels in the channel change menu.

QUOTE
thanks, just a note to them would be cool.
Done but no response as of yet. See http://forum.digitalspy.co.uk/board/showth...779#post8826779
BTW, The aduio now works fine from a fresh install in V70.
Go to the top of the page
 
+Quote Post
bear
post Jun 11 2006, 06:05 PM
Post #8


Forum Regular


Group: Members
Posts: 3,100
Joined: 24-April 04
From: Queensland
Member No.: 808
Card: VisionPlus DVB-t


hi anthonyshephard,
QUOTE
I had to. If I didn't do this, the networks still had the short name. Hence my comment about storing the long name regardless of the LongNetworkName setting in the Settings.xml file. I tried again with V70 anyway to make sure and the same behaviour.
The channel info is adequate to identify the mux's, its just that we are using the ONID value rather than the TSID value as the identifier for setting the channel. It would seem I need to change the method from looking for the ONID to the TSID which is unique to each mux. This may explain the problems with changing channels via timeshifting for UK users.

QUOTE
BTW, The aduio now works fine from a fresh install in V70.
Thanks, just keep an ear on it. laugh.gif

Hi spoonfed,
Can you try setting the Timeshift folder to an alternate HDD drive incase its choking the main drive.
Go to the top of the page
 
+Quote Post
Guest_Spoonfed_*
post Jun 11 2006, 06:34 PM
Post #9





Guests






QUOTE (bear @ Jun 11 2006, 06:05 PM) *
Hi spoonfed,
Can you try setting the Timeshift folder to an alternate HDD drive incase its choking the main drive.


Issue sort of seems a bit video decoder related, well maybe. Stuffed around with a "clean" version, managed to get it working with DScaler video, but then it stopped changing to Cyberlink7. BUT after stuffing a bit more this version is now working with Cyberlink7 it would appear, but if i duplicate all other settings on the other version (in another directory) cannot get it to work at all, weird as. Does not seem to matter what HD I use for timeshift.

Option i have are C: - Windows/programs D: partion no 60gb with C, just has documents/data etc
E: 2 x 60gbs in RAID0 (is is my normal timeshift/capture drive(s)
F: 1 x 80gb just music

Don't worry bear, this is my DTV life, always been able to have some stupid issue no one else does
laugh.gif
Go to the top of the page
 
+Quote Post
Guest_Spoonfed_*
post Jun 11 2006, 06:53 PM
Post #10





Guests






Update:
Can't seem to get consistancy. I can create a new version in C:\program files\digitalwatch2 and not have it work, yet will work in d:\software\digitalwatch2\bears.#*#(%\ these are on the same phsyical drive. Then i can simply change the timeshift folder in a working on to my Raid0 drive and then it wont work. BUT if i then create a new version on day E:\digitalwatch2 (ie on my Raid0 drive) and let it time shift in the default created drive for the moment its working blink.gif
If i do the same on D: drive (another sperate drive with just music on it) timeshift doenst work.

Maybe my computers possessed? unsure.gif ph34r.gif rolleyes.gif
Go to the top of the page
 
+Quote Post
bear
post Jun 11 2006, 07:42 PM
Post #11


Forum Regular


Group: Members
Posts: 3,100
Joined: 24-April 04
From: Queensland
Member No.: 808
Card: VisionPlus DVB-t


QUOTE
Maybe my computers possessed?
Sounds like the application is. laugh.gif

QUOTE
Issue sort of seems a bit video decoder related, well maybe. Stuffed around with a "clean" version, managed to get it working with DScaler video, but then it stopped changing to Cyberlink7. BUT after stuffing a bit more this version is now working with Cyberlink7 it would appear, but if i duplicate all other settings on the other version (in another directory) cannot get it to work at all, weird as. Does not seem to matter what HD I use for timeshift.
As far as using DScalar video decoder for timeshifting, I find it will not seek correctly when used with the TSFileSource so I don't use it, I may drop it from the decoders list to stop confusion, it was just in there from the beginning. All the others seem to work ok apart from the Aspect Ratio issues.

QUOTE
BUT if i then create a new version on day E:\digitalwatch2 (ie on my Raid0 drive) and let it time shift in the default created drive for the moment its working
Oh well, just keep it there for the time being and just move on. Then just test the other features.

QUOTE
Don't worry bear, this is my DTV life, always been able to have some stupid issue no one else does
It helps though in understanding what can go wrong since I don't have a range of system to test this on. smile.gif
Go to the top of the page
 
+Quote Post
bear
post Jun 13 2006, 11:42 PM
Post #12


Forum Regular


Group: Members
Posts: 3,100
Joined: 24-April 04
From: Queensland
Member No.: 808
Card: VisionPlus DVB-t


hi all,

Version 2.0.7.1 is up, see first post for details.

Changes:

UK users should be able to navigate their mux services with the changes to the SetChannel() method to use the TSID value rather than ONID.

The OSD navigation should now be quicker with the addition of a buffer log thread and a message limit value set in the settings.xml, you can now specify how many messages are buffered before a file write is made to the log, default value is 100. Setting the value to 0 will cause the log to write to file immediate. It also now writes to the file with a low priority.
Go to the top of the page
 
+Quote Post
rpalmer68
post Jun 14 2006, 12:06 AM
Post #13


Forum Regular


Group: Members
Posts: 240
Joined: 27-August 05
From: Sydney, Australia
Member No.: 3,513
Card: DNTV tinyUSB


hi bear,

Looking good, I'd better get cracking with the manual! I just need to convince my 10 month old that Daddy need time to play on the computer without "help" smile.gif

Just a few items (mostly minor)
1) I haven't tried V71, but in V70 I noticed I was gettig a brief bit of static in my speakers at channel change (liek a loud chirp for a split second), and I didn't with previous versions. Do you mute/unmute the sound during a change?

2) The decoder test results are obscured by the Decoder list in the OSD (especially the failed message), could the results be lower on the screen so we can read them please?

3) If I press F2 and try to scan a network in TS mode it doesn't scan I get a © on the screen showing TS is changing channel and then a blank screen. Works fine in TV mode.

4) Do we need the © on channel change in TS mode? Just looks a bit out of place.

5) In the Settings OSD, would it be possible to display the current setting for things like Timeshift Path, Capture Path and Capture name at the bottom of the screen when these settings are selected, this way a user can see if they are set correctly or need changing. Just like you have for the decoders screen.

Must say DW has been very stable for me in recent times, I switch from TV to TS and jump channels a lot and haven't had any surprises as yet!

Great job.

Richard

This post has been edited by rpalmer68: Jun 14 2006, 12:06 AM
Go to the top of the page
 
+Quote Post
anthonyshephard
post Jun 14 2006, 05:44 AM
Post #14


Forum Regular


Group: Members
Posts: 141
Joined: 21-November 04
Member No.: 2,060
Card: VisionPlus DVB-t


QUOTE
Version 2.0.7.1 ...
UK users should be able to navigate their mux services with the changes to the SetChannel() method to use the TSID value rather than ONID.
Yes I can. Thanks!! What order are the channels sorted by? I would have thought the number they start with would be logical but I get
7 BBC THREE, 80 NEWS 24, 105 BBCi, 70 CBBC, 2 BBC TWO, 1 BBC ONE.

But Timeshifting still doesn't work.
First problem. If I incorrectly use the wrong version of TSFileSource (as installed by MediaPortal without asking!) it crashes DWII.
Second. With timeshifting enabled, no audio. But I can change channels properly. Log attached;
Third. Sometimes I get a crash in digitalwatch.exe. Happens if I go into TV mode from the menu, then F1 then enable Timeshifting (with the correct version of TSFileSource). Also tried moving from TV to Timeshift and back again. After about six times, another crash.

QUOTE
The OSD navigation should now be quicker with the addition of a buffer log thread

Yup, don't get the same problem when I remove the log exclusion from VirusScanner.
Attached File(s)
Attached File  DigitalWatch_crash.zip ( 2.05K ) Number of downloads: 26
Attached File  DigitalWatch.zip ( 2.75K ) Number of downloads: 29
 
Go to the top of the page
 
+Quote Post
bear
post Jun 14 2006, 06:42 AM
Post #15


Forum Regular


Group: Members
Posts: 3,100
Joined: 24-April 04
From: Queensland
Member No.: 808
Card: VisionPlus DVB-t


hi richard,[quote]I just need to convince my 10 month old that Daddy need time to play on the computer without "help"[/quote]Trust me, playing with your 10 month old is more fun. The manual can wait.

[quote]1) I haven't tried V71, but in V70 I noticed I was gettig a brief bit of static in my speakers at channel change (liek a loud chirp for a split second), and I didn't with previous versions. Do you mute/unmute the sound during a change?[/quote]I can't say I've seen this but it would be a good idea anyway, thanks I'll add it in the "To Be Done now" list

[quote]2) The decoder test results are obscured by the Decoder list in the OSD (especially the failed message), could the results be lower on the screen so we can read them please?[/quote]ok, but i'm running out of room on the screen. dry.gif

[quote]3) If I press F2 and try to scan a network in TS mode it doesn't scan I get a © on the screen showing TS is changing channel and then a blank screen. Works fine in TV mode.[/quote]Looks as if I've broken something, did work before from memory.

[quote]4) Do we need the © on channel change in TS mode? Just looks a bit out of place.[/quote]Prob not, it was there for testing and to give you a positive indication that you are changing something, else you might think you had not pressed the change key and end up skipping the channel you wanted.

[quote]5) In the Settings OSD, would it be possible to display the current setting for things like Timeshift Path, Capture Path and Capture name at the bottom of the screen when these settings are selected, this way a user can see if they are set correctly or need changing. Just like you have for the decoders screen. [/quote] Fair comment, I was just lazy in not adding it in to the OSD script.

[quote]Must say DW has been very stable for me in recent times, I switch from TV to TS and jump channels a lot and haven't had any surprises as yet![/quote] Cool, although I seem to have added a bug in the 2.0.7.1 version. oh well. rolleyes.gif

hi anthony,
[quote]What order are the channels sorted by? I would have thought the number they start with would be logical but I get
7 BBC THREE, 80 NEWS 24, 105 BBCi, 70 CBBC, 2 BBC TWO, 1 BBC ONE.[/quote]Here in AU our channels are in order since thats how they are presented in each mux, I had not given too much thought to ordering, do you think an option should be included to order by channel number, service name?

[quote]First problem. If I incorrectly use the wrong version of TSFileSource (as installed by MediaPortal without asking!) it crashes DWII.[/quote]hmm, I guess there are some things that can't be helped. It's possible that older version is quite outdated, when you try a new version of DWII first unzip to a new directory and run it to register the new filter in that location. You can then play with it until your happy that it works ok then move the directory and run the register file again. As long as MP doesn't crash with the new TSFileSource from DW then all should be ok. If your updating MP from the SVN then you can comment out the register command in the postbuild.bat to stop it registering the old TSFileSource.

[quote]Second. With timeshifting enabled, no audio. But I can change channels properly. Log attached;[/quote]Thanks, I'll look into that.

[quote]Third. Sometimes I get a crash in digitalwatch.exe. Happens if I go into TV mode from the menu, then F1 then enable Timeshifting (with the correct version of TSFileSource). Also tried moving from TV to Timeshift and back again. After about six times, another crash. [/quote] Yes I can see this now, it's a timming issue with the new log buffer code, a bit like the "chicken before the egg" issue since it doesn't seem happen in debug mode.
[quote]Yup, don't get the same problem when I remove the log exclusion from VirusScanner.[/quote]Cool, at least thats been solved. dry.gif
Go to the top of the page
 
+Quote Post
anthonyshephard
post Jun 14 2006, 07:24 AM
Post #16


Forum Regular


Group: Members
Posts: 141
Joined: 21-November 04
Member No.: 2,060
Card: VisionPlus DVB-t


Hi Bear,
QUOTE
do you think an option should be included to order by channel number, service name?
That would be logical. Most other applications don't present the network information and just list by channel number. This could be another option.
QUOTE
When you try a new version of DWII first unzip to a new directory and run it to register the new filter in that location

The stupid MP installer copies the TSFileSource.ax file to the SYSTEM32 directory which takes precedence of any registering that you do. It seems to do it automatically with the SVN for some reason (perhaps a dependency with the installer that thinks it is cleverer than I am). I know I should be able to remember but I have forgotten now about three times. Still hopefully MP will update to the new version soon enough.

Anthony
Go to the top of the page
 
+Quote Post
rpalmer68
post Jun 14 2006, 08:06 AM
Post #17


Forum Regular


Group: Members
Posts: 240
Joined: 27-August 05
From: Sydney, Australia
Member No.: 3,513
Card: DNTV tinyUSB


QUOTE (anthonyshephard @ Jun 14 2006, 07:24 AM) *
The stupid MP installer copies the TSFileSource.ax file to the SYSTEM32 directory which takes precedence of any registering that you do. It seems to do it automatically with the SVN for some reason (perhaps a dependency with the installer that thinks it is cleverer than I am). I know I should be able to remember but I have forgotten now about three times. Still hopefully MP will update to the new version soon enough.


bear,

Any way of DW testing for the correct version at startup and warning if it's not correct? As this filter is critical for correct operation.

R
Go to the top of the page
 
+Quote Post
uryan
post Jun 14 2006, 01:49 PM
Post #18


Forum Regular


Group: New Members
Posts: 307
Joined: 3-June 06
Member No.: 4,853
Card: None


Bear,
I did some more testing with the aspect ratio issue and have come to the conclusion that there is a bug in the aspect ratio overide option. Rather than setting the aspect ratio specified it goes in steps as follows:

When override=True
If set aspect ratio (SAR) is less than 1:1 then it fails (filtergraph is empty)
If 1:1 <= SAR < 2:1, then displayed aspect ratio (DAR) is 1.05:1 (e.g. when SAR is 4:3 or 16:9)
If 2:1 <= SAR < 3:1, then DAR is 1.91:1 (this is close, but a bit to wide for 16:9 display)
If 3:1 <= SAR < 4:1, then DAR is 2.86:1
If 4:1 <= SAR < 5:1, then DAR is 3.82:1
etc.

this is true with all decoders i tested, including ones that work properly with override=false (yes I finally found some)

Also while testing I found Elecard's decoder had issues changing channels. The video gets corrupted and the only fix is to restart the graph This was with version 2, which I got with ProgDVB as well as v4 which I downloaded the trial to test.

Anyway, here are a few more decoders to add to the list:

- Leadtek DTV Decoder - Supports HD, AR is OK, low CPU usage (supports DXVA), good deinterlacing (This is a rebranded Cyberlink decoder) It's all good!

- Ulead MPEG Video Decoder - SD only, AR is OK, high CPU

- Ulead DVD Video Decoder - SD only, AR problems, high CPU

- Elecard MPEG-2 Video decoder 4 - Supports HD, AR is OK, is meant to support DXVA but didn't work on my system, defaults to no deinterlacing(since you can't change the settings in DW you are stuck with the default), problems changing channel


<Decoder name="LeadTek DTV Video Decoder">
<MediaType name="MPEG2 Video" />

<LoadFilter clsid="{64AFB6CB-A4F9-44D8-864A-4598A1BE5CE0}" name="LeadTek DTV Video Decoder" />
<InputFilter name="LeadTek DTV Video Decoder" />
<VideoRenderer name="Overlay Mixer" />

<Connect>
<From name="LeadTek DTV Video Decoder" />
<To name="Overlay Mixer" />
</>
</Decoder>

<Decoder name="Ulead MPEG Video Decoder">
<MediaType name="MPEG2 Video" />

<LoadFilter clsid="{CF957F40-77FE-4192-A59F-95CA43BD04BA}" name="Ulead MPEG Video Decoder" />
<InputFilter name="Ulead MPEG Video Decoder" />
<VideoRenderer name="Overlay Mixer" />

<Connect>
<From name="Ulead MPEG Video Decoder" />
<To name="Overlay Mixer" />
</>
</Decoder>


<Decoder name="Ulead DVD Video decoder 2">
<MediaType name="MPEG2 Video" />

<LoadFilter clsid="{7AB72E17-9774-4FEB-AC0F-0025E7209C47}" name="Ulead DVD Video decoder 2" />
<InputFilter name="Ulead DVD Video decoder 2" />
<VideoRenderer name="Overlay Mixer" />

<Connect>
<From name="Ulead DVD Video decoder 2" />
<To name="Overlay Mixer" />
</>
</Decoder>

<Decoder name="Elecard MPEG-2 Video Decoder 4">
<MediaType name="MPEG2 Video" />

<LoadFilter clsid="{BC4EB321-771F-4E9F-AF67-37C631ECA106}" name="Elecard MPEG-2 Video Decoder" />
<InputFilter name="Elecard MPEG-2 Video Decoder" />
<VideoRenderer name="Overlay Mixer" />

<Connect>
<From name="Elecard MPEG-2 Video Decoder" />
<To name="Overlay Mixer" />
</>
</Decoder>

Also, the Cyberlink7 decoder I have been using is actually called "Cyberlink Video/SP Decoder" but has the same CLSID as the Cyberlink7 one and works with those settings. I acquired it with PowerDVD 6 OEM (Just pointing it out because it was hard to find initially, since neither Cyberlink6 nor Cyberlink PowerDVD settings worked)
Go to the top of the page
 
+Quote Post
vadimz
post Jun 14 2006, 01:54 PM
Post #19


Participant


Group: Members
Posts: 47
Joined: 3-November 03
Member No.: 238
Card: VisionPlus DVB-t


Bear,

Great progress you're making with DW2, and the builds keep coming so quick... biggrin.gif

But with all builds I have a problem with screen offset by about 100 pixels down and 100 to the right within DW window. I've played aspect setting, but it didn't help. I'm using a different resolution to you. I'm on 720x576. Would that make a difference?

I have a few random questions / suggestions

* Looking at your work with OSD, you can do quite complex setups now. So I was thinking could we get a ShellExecute function implemented in OSD. This will make it possible to call other apps from DW OSD menu.

* It would be really useful if DW OSD could display a full scrollable EPG info like WS in keyboard mode. With events triggered on selection.

* Any chance of implementing DVB-S ? I realize that you (bear) probably don't have a satellite card, but I'm sure there are plenty of users that will test it for you, including me. tongue.gif

will test 71 when I get home.

Vad.

This post has been edited by vadimz: Jun 14 2006, 01:57 PM
Go to the top of the page
 
+Quote Post
bear
post Jun 15 2006, 09:00 AM
Post #20


Forum Regular


Group: Members
Posts: 3,100
Joined: 24-April 04
From: Queensland
Member No.: 808
Card: VisionPlus DVB-t


hi everyone,

I'll respond to the latest posts soon, but I just want to let you know that vers 2.0.7.2 is up for testing,
just some fixes I hope to a few issues.

- Added in some audio muting when changing channels.
- Made some changes to fix the multiple audio stream problem when timeshifting. @anthony, if you could try this, thanks.
- Fixed a bug that was causing crashes when accessing the message log writer. I think.
- Added in a option setting to the OSD menu global settings to enable ordering of the services by channel numbers. Default setting is enabled.

Note: As my local ISP, who was recently bought out by telstra, is now being closed down, it may be a while before I can get internet access so there maybe a short pause with my development of DWII.
Go to the top of the page
 
+Quote Post

6 Pages V   1 2 3 > » 
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th July 2019 - 07:33 AM