Printable Version of Topic

Click here to view this topic in its original format

DVB Owners Discussion Forum - dvbowners.com _ HIP _ HIP won't run for different user account

Posted by: ksipp0 Apr 5 2008, 04:51 AM

I'm trying to setup another user account w/ bare bones stuff (for my wife) MCE2005 and HIP. I can't get hip to start from the startup menu. I also can't run hip unless i "run as" the user account that i originally installed hip in(which is administrator). This is the error i get:

Exception in module 0008FB2
Error writing to c:\program files\HIP\LASTFILE.TXT

I don't 'link' to any programs that are unaccessable to the new user (at least i think). The only thing I can think might be related is a secondary command for the STOP key that does this: (not sure if related)

EXEC(C:\Program Files\Stop Live TV\STOP Live TV.mcl|||STOP Live TV.mcl|1)
but this runs just fine if i execute from "other programs" in MCE

Thank-you!

Posted by: btmi Apr 5 2008, 10:18 AM

It has to be a permissions problem...you might have to make the Hip directory writable in all profiles - it is clear that the profile for your wife only allows read-only access to the "Program Files" directory which is where Hip has a problem.

One easy workaround may be to reinstall Hip into a different directory(not in "Program Files").

Posted by: ksipp0 Apr 10 2008, 07:35 AM

Thanks for the quick response. I actually gave the account admin. privileges and now it works.....UNLESS it's ALSO running in 'my' account. It starts ok, but no response from remote. icon doesn't change to red w/ remote button pushes. End it in the other account...no problems,

any way around this??
Thanks

Posted by: btmi Apr 10 2008, 09:23 AM

Most IR devices will only allow control by one program at a time, and so to have Hip running in 2 accounts simultaneously is something that I am sure would lead to a number of problems that I am afraid I would not know how to solve.

Posted by: lmo Aug 9 2011, 04:47 AM

If you add the account to the "<machine>\Power Users" group, HIP will work when invoked as a non-admin user account.
My setup is WinXP MCE SP3 with latest updates.
Failing this, I would try making c:\<program files>\hip directory writable by the user or the "<machine>\Users" group.

Powered by Invision Power Board (http://www.invisionboard.com)
© Invision Power Services (http://www.invisionpower.com)